Providers unable to access certain features within the provider portal

Incident Report for Headway

Resolved

The issue impacting the ability to access session confirmation and appointment scheduling has been resolved. The provider portal is fully operational.
Posted May 19, 2026 - 18:56 EDT

Monitoring

Issue detected: We've identified an issue impacting the ability to access certain features within the provider portal, including session confirmation and appointment scheduling. We've put a fix in place and are monitoring.
Posted May 19, 2026 - 18:28 EDT
This incident affected: headway.co.